CatApp step 63 anchor and href

So, this doesn’t make sense to me. how does this href= apply to freecodecamp . org when freecodecamp . org is not within the anchor? also when I typed it in, the < / a > was a light blue and it worked. All the other times I tried an element that was not dark blue but orange, white, or light blue, it wouldn’t work, but this time it did… maybe coding is so nuanced that what seem to be the rules keep changing as you go along?
(I had to put spaces in < / a > so it shows up in this post btw. Yet another thing that I don’t understand)
No Copyright - <a href="https://www.freecodecamp . org" < / a > freeCodeCamp . org

how does it not apply to No Copyright - ?

This is my very first attempt at learning to code by the way.
Thanks

You don’t have a closing > on your opening a tag. Also, the closing /a tag needs to come after the text that is being turned into a link.

Yes! Exactly what I thought, but when I would do that, it wouldn’t work. I finally got it to work by typing in what I have above. Maybe there is a mistake in the lesson and it should be brought to codecamp’s attention.

The challenge passes with correct code. What is your code with those fixes I pointed out?

I took a screenshot of the challenge passing with the incorrect code if you want me to send it to you. (it’s the very same as a put in the original post) I looked at the correct code in the next steps and it is just as you said it should be.

Also, I should point out that I arrived at the wrong code that let me pass by doing whatever I had to do to make the colors of the text work out. when I put in the correct code (what it should be), it showed all white text and wouldn’t pass. I finagled the dang thing til it worked

Are you saying that the wrong code in your first post actually passes?

Edit: Huh, it does pass but it really shouldn’t since that code is wrong. The correct code certainly does pass though.