Celestial Bodies Database - Build a Celestial Bodies Database

I am done with the challenge tried to submit but its saying i should complete the project first.

Already taken the dump file too. Any Suggestions with what i should do?

solution: GitHub - DanneeArts/universe.sql

Link to the challenge:

hi, what URL were you trying to use?

GitHub - DanneeArts/universe.sql

this one

ok, that doesn’t look like the correct url for this.
You need the repository URL instead.

1 Like

I just created this one but it still didnt pass the test

What url did you use?

solution: GitHub - DanneeArts/new-repository

try the url of the repo which is

that’s the url I used

hmm, can you try to apply the sql file to your workspace and see if the checks are showing as passing?

rebuild the database by entering psql -U postgres < universe.sql in a terminal where the .sql file is.

(is it possible you missed one?)

this is a screenshot of the dump, coderoad and the when i rebuilt the database

I don’t know why, but in the past someone had a similar issue and it was suggested to them that the troubleshooting step #3 is to be used

To save your progress on freeCodeCamp.org , you will need to be signed in. Click the sign in button at the top right and sign in if you aren’t already

So can you exit this course. Then double check that you are signed into fCC.
Then start another course (it can be an old one). Then wait for that to load the virtual machine and then exit that one.
Then again retry to get in to the Celestial one.
Then re-apply the SQL.
Then re-try the URL?

1 Like

thanks alot
it worked

1 Like