"Change the CSS of an Element Using jQuery" not working

Tell us what’s happening:
Describe your issue in detail here.
This code doesn’t seem to work, the solution is listed here (From “Get Help” > “Get a Hint”) is not correct because the question here asks to delete jQuery selectors before adding the red text". Could someone fix this challenge so I move forward in earning this certificate .

  **Your code so far**

<script>
$(document).ready(function() {
$("#target1").css("color", "red");
});
</script>

<!-- Only change code above this line -->

<div class="container-fluid">
<h3 class="text-primary text-center">jQuery Playground</h3>
<div class="row">
  <div class="col-xs-6">
    <h4>#left-well</h4>
    <div class="well" id="left-well">
      <button class="btn btn-default target" id="target1">#target1</button>
      <button class="btn btn-default target" id="target2">#target2</button>
      <button class="btn btn-default target" id="target3">#target3</button>
    </div>
  </div>
  <div class="col-xs-6">
    <h4>#right-well</h4>
    <div class="well" id="right-well">
      <button class="btn btn-default target" id="target4">#target4</button>
      <button class="btn btn-default target" id="target5">#target5</button>
      <button class="btn btn-default target" id="target6">#target6</button>
    </div>
  </div>
</div>
</div>
  **Your browser information:**

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36

Challenge: Change the CSS of an Element Using jQuery

Link to the challenge:

Hi @Ghost6Fire !

I have gone ahead and updated the guide solution.

The code you have shared works on my end. Please ensure that you have disabled any extensions that interface with the freeCodeCamp website (such as Dark Mode and Ad Blocker), and set your browser zoom level to 100%. Both of these factors can cause tests to fail erroneously.

You can move onto the next challenge.
Challenges do no count towards the certificate.
Only projects do.

Hope that helps!

1 Like

It appears the “Dark Reader” extension was the problem. Thanks

1 Like