Clone an Element Using jQuery Clone doesn't Submit

Clone an Element Using jQuery Clone doesn't Submit
0

#1

It won’t let me submit.

It shows this:

x A copy of your target5 element should also be inside your left-well.

What is wrong?

Thanks for your help!
Marilyn

Your code so far

<script>
  $(document).ready(function() {
    $("#target1").css("color", "red");
    $("#target1").prop("disabled", true);
    $("#target4").remove();
    $("#target2").appendTo("#right-well");
    $("#target5").clone().appendTo("leftwell");
  });
</script>

<!-- Only change code above this line. -->

<div class="container-fluid">
  <h3 class="text-primary text-center">jQuery Playground</h3>
  <div class="row">
    <div class="col-xs-6">
      <h4>#left-well</h4>
      <div class="well" id="left-well">
        <button class="btn btn-default target" id="target1">#target1</button>
        <button class="btn btn-default target" id="target2">#target2</button>
        <button class="btn btn-default target" id="target3">#target3</button>
      </div>
    </div>
    <div class="col-xs-6">
      <h4>#right-well</h4>
      <div class="well" id="right-well">
        <button class="btn btn-default target" id="target4">#target4</button>
        <button class="btn btn-default target" id="target5">#target5</button>
        <button class="btn btn-default target" id="target6">#target6</button>
      </div>
    </div>
  </div>
</div>

Your browser information:

Your Browser User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/604.4.7 (KHTML, like Gecko) Version/11.0.2 Safari/604.4.7.

Link to the challenge:


#2

Mind the selector of your appendTo function:

$("#target5").clone().appendTo("leftwell");

#3

You have a typo in the above as pointed out by @Marmiz.


#4

Is it the hashtag in front of left-well? I added that but still not submitting.


#5

I found it the dash in the left-well plus the hashtag.

Thanks for your assistance!