Connection issues when attempting to submit and go to next challenge and unsaved progress

I’m consistently having an issue when I attempt to submit my solution and go to the next challenge wherein clicking the button does nothing for a good while. I can close the pop-up window, run the test again and attempt to submit over and over but until it’s done hanging, it won’t move on to the next challenge. When it does move on to the next challenge, it will not have saved the progress (but it will have saved the solution), so I need to go back each time I experience this issue and resubmit my solution.

It is like the connection to freecodecamp.org just completely dies. While it is hanging this way, I cannot even access the freecodecamp.org domain in another tab - it just refuses to resolve. I have connection issues with absolutely no other site on the web, I have a consistent connection. Despite this, I will occasionally get the “looks like you’re offline” banner. This doesn’t tend to coincide with my issue. For all I know, the connection could die prior to me attempting to submit my solution.

If I hard refresh the page (ctrl+f5) when it hangs, I can generally submit my solution and briefly not run into this issue.

I have disabled extensions, cleared browser data and cache, tried another browser (typically use Firefox 88.0.1, tried the most recent version of Edge and experienced the same problem), flushed DNS, switched from quad9 to cloudflare DNS to see if that’s the problem, and my issue does not go away.

This issue is making it incredibly frustrating and difficult for me to study using freeCodeCamp as it honestly takes me much longer to get anything done.

I really hope that I can get this sorted out and I’m incredibly grateful for the work of the entire freeCodeCamp team.