Create a Set of Radio Buttons Bug

Create a Set of Radio Buttons Bug
0

#1

Tell us what’s happening:

Just reporting a bug in the system. I’m sure my code is fine

Your code so far


<h2>CatPhotoApp</h2>
<main>
  <p>Click here to view more <a href="#">cat photos</a>.</p>
  
  <a href="#"><img src="https://bit.ly/fcc-relaxing-cat" alt="A cute orange cat lying on its back."></a>
  
  <p>Things cats love:</p>
  <ul>
    <li>cat nip</li>
    <li>laser pointers</li>
    <li>lasagna</li>
  </ul>
  <p>Top 3 things cats hate:</p>
  <ol>
    <li>flea treatment</li>
    <li>thunder</li>
    <li>other cats</li>
  </ol>
  <form action="/submit-cat-photo">
    <label for="indoor">
      <input id="indoor" type:"radio" name="indoor-outdoor"> Indoor
    </label>
    <label for="outdoor">
      <input id="outdoor" type="radio" name="indoor-outdoor"> Outdoor
    </label>

    <input type="text" placeholder="cat photo URL" required>
    <button type="submit">Submit</button>
  </form>
</main>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/responsive-web-design/basic-html-and-html5/create-a-set-of-radio-buttons


#2

It’s not a bug, your code has a typo.


#3

Expanding on @zapcannon99’s response: How do you correctly assign a value to an element attribute?


#4

There’s a typo at your first button
type=“radio”
not type: “radio”


#5

You are right guys!
Thanks for the help.
I ran the test, and it worked flawlessly!