Data Analysis with Python Projects - Medical Data Visualizer

Tell us what’s happening:

There an issue with poetry for this project,
Here’s the issue "–> poetry add numpy matplotlib
Using version ^1.26.3 for numpy
Using version ^3.8.2 for matplotlib

Updating dependencies
Resolving dependencies…

The current project’s Python requirement (>=3.7,<4.0) is not compatible with some of the required packages Python requirement:

  • matplotlib requires Python >=3.9, so it will not be satisfied for Python >=3.7,<3.9

Because no versions of matplotlib match >3.8.2,<4.0.0
and matplotlib (3.8.2) requires Python >=3.9, matplotlib is forbidden.
So, because root depends on matplotlib (^3.8.2), version solving failed.

• Check your dependencies Python requirement: The Python requirement can be specified via the python or markers properties

For matplotlib, a possible solution would be to set the `python` property to ">=3.9,<4.0"

https://python-poetry.org/docs/dependency-specification/#python-restricted-dependencies,
https://python-poetry.org/docs/dependency-specification/#using-environment-markers

exit status 1"

And there is also “Traceback (most recent call last):
File “/home/runner/boilerplate-medical-data-visualizer/main.py”, line 2, in
import medical_data_visualizer
File “/home/runner/boilerplate-medical-data-visualizer/medical_data_visualizer.py”, line 1, in
import pandas as pd
ModuleNotFoundError: No module named ‘pandas’”

Your code so far

Just that isn’t working
“import pandas as pd
import seaborn as sns
import matplotlib.pyplot as plt
import numpy as np”

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:121.0) Gecko/20100101 Firefox/121.0

Challenge Information:

Data Analysis with Python Projects - Medical Data Visualizer