Data Analysis with Python Projects - Page View Time Series Visualizer

Tell us what’s happening:

Describe your issue in detail here.

I have wrote my code locally however I am unable to run it in the link below as it keeps erroring when trying to install packages. I cannot see a way around this.

I am not presented with the below option.

Select Use run command and click the Done button.

I would greatly appreciate it if you could advise.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/119.0

Challenge Information:

Data Analysis with Python Projects - Page View Time Series Visualizer

Try typing pip install pandas at the shell command prompt

Hello pkdvalis,

I have installed pandas however, I still receive errors.

Any other ideas?

Thank you in advance

Is it the same error or a different error as before?

Can you put it in here just o make sure we’re discussing the same thing.

Currently I’m seeing this error:

Traceback (most recent call last):
  File "/home/runner/222765699/", line 2, in <module>
    import time_series_visualizer
  File "/home/runner/222765699/", line 1, in <module>
    import matplotlib.pyplot as plt
  File "/home/runner/222765699/.pythonlibs/lib/python3.10/site-packages/matplotlib/", line 66, in <module>
    from matplotlib.figure import Figure, FigureBase, figaspect
  File "/home/runner/222765699/.pythonlibs/lib/python3.10/site-packages/matplotlib/", line 43, in <module>
    from matplotlib import _blocking_input, backend_bases, _docstring, projections
  File "/home/runner/222765699/.pythonlibs/lib/python3.10/site-packages/matplotlib/projections/", line 55, in <module>
    from .. import axes, _docstring
  File "/home/runner/222765699/.pythonlibs/lib/python3.10/site-packages/matplotlib/axes/", line 2, in <module>
    from ._axes import *
  File "/home/runner/222765699/.pythonlibs/lib/python3.10/site-packages/matplotlib/axes/", line 11, in <module>
    import matplotlib.category  # Register category unit converter as side effect.
  File "/home/runner/222765699/.pythonlibs/lib/python3.10/site-packages/matplotlib/", line 14, in <module>
    import dateutil.parser
ModuleNotFoundError: No module named 'dateutil.parser'
exit status 1

Not super clear but it seems to happen while importing matplotlib.

Try pip install matplotlib

Hello pkdvalis,

I have installed matplotlib and seaborn however they are both underlined in red suggesting they are not installed.

Any ideas?

Thanks again

Cannot replicate that, sorry. I wouldn’t worry about that until it creates an error.

I ran your code and imports of matplotlib and seaborn caused no error, so they are installed.

I got this error:

Traceback (most recent call last):
  File "/home/runner/Chris1990-page-view-time-series-visualizer-1/", line 6, in <module>
  File "/home/runner/Chris1990-page-view-time-series-visualizer-1/", line 22, in draw_line_plot
NameError: name 'fig' is not defined

Screenshot 2023-10-26 171100

There is a lot of preamble and errors when you open this “Packager” tab:

Try deleting the hidden files poetry.lock and pyproject.toml and replit.nix. That’s what I did and this fork seems to run better: You could fork that if you want to.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.