Disable an Element Using jQuery (bugged?)

Disable an Element Using jQuery (bugged?)
0.0 0

#1

Tell us what’s happening:

Is this task bugged? I cannot click the ‘run test’ button, nothing happens not even a fail or error.

Your code so far

<script>
  $(document).ready(function() {
    $("#target1").css("color", "red");
    $("#target1").prop("disabled", true);
  });
</script>

<!-- Only change code above this line. -->

<div class="container-fluid">
  <h3 class="text-primary text-center">jQuery Playground</h3>
  <div class="row">
    <div class="col-xs-6">
      <h4>#left-well</h4>
      <div class="well" id="left-well">
        <button class="btn btn-default target" id="target1">#target1</button>
        <button class="btn btn-default target" id="target2">#target2</button>
        <button class="btn btn-default target" id="target3">#target3</button>
      </div>
    </div>
    <div class="col-xs-6">
      <h4>#right-well</h4>
      <div class="well" id="right-well">
        <button class="btn btn-default target" id="target4">#target4</button>
        <button class="btn btn-default target" id="target5">#target5</button>
        <button class="btn btn-default target" id="target6">#target6</button>
      </div>
    </div>
  </div>
</div>

Your browser information:

Your Browser User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0.

Link to the challenge:
https://www.freecodecamp.org/challenges/disable-an-element-using-jquery


#3

I cannot reproduce this problem. Please create a detailed GitHub Issue which includes all of your browser information.


#4

I had the same problem with this task.
I thought that something was wrong with my browser (FF59), so I tried Chrome and then FF for Android without any luck.
I managed to pass this task by booting Windows 10. Previously I tried to do it on Fedora 27. I have no idea why would it change anything but it worked for me.

I hope it helps to anyone who might have the same problem in the future.


#5

yep - same issue here. will check the gitbub.