Failing to use Glitch link to pass my first mongodb challenge

I don’t know what I am doing wrong. I have tried answers from other people’s questions but it still doesn’t help.
This is the link to my challenge:

and this is the link to my glitch project that I tried to share with FCC:

I have already added MongoDB and mongoose to the dependencies and all the other requirements but it is still failing.

The test results are either timed out or they just fail. Please help. I need this to proceed, I have never had to use glitch before even with other FCC challenges, though I haven’t used FCC in a while. Thank you.


Theres no MONGO_URI variable in your .env

See Introduction to the MongoDB and Mongoose Challenges for instructions


@Annestezia hello, the MONGO_URI is already set actually in my .env file. and for some reason, my project is not waking up when i click on show. Do you have any advice on that. I dont know if its working on your side.

I put together code link manually, I can see your code!/shaded-meteor-energy , but your .env file is empty.

The .env file is for storing secrets for your app, like an API key. Any project member can see the contents in the same way that you can, and everyone else can just see the variable names.

That’s what I see when I run live app from editor

failed to start application on This is most likely because your project has a code error. Check your project logs, fix the error and try again.

And there’s this line in you code require('dotenv/config'); but dotenv is missing in package.json

Advice hmm comment out missing package require, check logs and fix error and try again :upside_down_face: or start over maybe? There’s not much done yet

Glitch is failing from time to time , but not all the time.

@Annestezia Hello. Thank you for your reply. I have finally solved the problem. The issue was that I hadn’t put dotenv in the package.json file just like you noticed. Adding it resolved my issue like a charm.

Thank you alot.

1 Like