[FIXED]Help Deciphering Replit Assertion Error for Arithmetic Arranger(code and error message provided)

Edit: This has been solved, it was just a typo
I am trying to solve the Arithmetic Arranger final project for the Scientific Python course, and I am running into 2 errors that I can’t figure out.
When I run the program with the same arguments in the terminal, I get the expected output, but when I run them in replit, I get these Assertion Errors. I get that this means my output is not identical to the expected output, but why does it abbreviate the asserted output and my actual output?

For example: assert ’ 3 9…---- -----’ == ’ 3 9… 858 1028’

Why does it use an ellipses to abbreviate the assertions so that I can’t tell what it is looking for or what was different with my result?

Also, what does it mean by: Skipping 33 identical leading characters in diff, use -v to show

I have included images of the errors in question and a link to the code.

code: boilerplate-arithmetic-formatter - Replit


fixed. Typo on line 97. ‘solved’ should be ‘solve’


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.