Height of an Element not adjusting using the height Property

Height of an Element not adjusting using the height Property
0.0 0

#1

Tell us what’s happening:
i think my code is right but still it shows error in the code. i had reset the code and tried again but the result was same.

Your code so far


<style>
  h4 {
    
    text-align: center;
    height: 25px;
  }
  p {
    text-align: justify;
  }
  .links {
    margin-right: 20px;
    text-align: left;
  }
  .fullCard {
    width: 245px;
    border: 1px solid #ccc;
    border-radius: 5px;
    margin: 10px 5px;
    padding: 4px;
  }
  .cardContent {
    padding: 10px;
  }
</style>
<div class="fullCard">
  <div class="cardContent">
    <div class="cardText">
      <h4>Google</h4>
      <p>Google was founded by Larry Page and Sergey Brin while they were Ph.D. students at Stanford University.</p>
    </div>
    <div class="cardLinks">
      <a href="https://en.wikipedia.org/wiki/Larry_Page" target="_blank" class="links">Larry Page</a>
      <a href="https://en.wikipedia.org/wiki/Sergey_Brin" target="_blank" class="links">Sergey Brin</a>
    </div>
  </div>
</div>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.79 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/responsive-web-design/applied-visual-design/adjust-the-height-of-an-element-using-the-height-property


#2

Hi! I copied & pasted your code in my browser and it is working fine. I also face the same problem sometimes, may be some kind of bug. Just close the browser tab and try the same in a new tab. It should work. Thanks.


#3

I did what you said in chrome but it’s still not working. In internet explorer the code is stuck on ‘running test’ and in Morzilla Firefox the even the curriculum is not opening.


#4

I tried your code in Firefox and chrome and it is working. I am not sure what is the problem but it is definitely not related to your code or your browser since I am using the same chrome browser as you are.
Sorry for not being able to help you.


#5

ok this may sound weird but i tried the code on my phone’s Chrome and the challenge was completed. So the problem MIGHT be with my laptop. I have tried lot of things like installing chrome again, restarting etc but nothing happened and atlast I used my phone to complete the task.


#6

More like a bug with freecodecamp than you laptop I think. They recently updated it and problems have been pupping up.


#7

Hey, I bumped into this problem too.
I reset my zoom level to 100% on Chrome and tried again.
It passed!

I think the bug comes from the way the tests are performed, in a previous challenge dealing with the image width in the Cat Photo App the same issue was resolved by setting the zoom