Help with Android SDK and eclipse IDE

Help with Android SDK and eclipse IDE
0.0 0

#1

My question is do I need to have an android SDK package saved to start a new android project, even if I don’t want to run it. And do I need the SDK to create an android virtual device in eclipse.

My problem in detail: I’ve finally cleared the necessary space on my machine and downloaded eclipse ide and the jdk 8.
I’ve been coding in java for a couple days but my main focus is to make android apps.
So I downloaded the android sdk, and I set the location in eclipse using eclipse preferences.
But whenever I try to start a new android application project, after I enter the name of the app the next and finish buttons are grayed out(also when I click the drop down list for compile with there are no options to choose from).
Also the same problem when I try to create new AVD. The after filling out information the ok button is grayed out. Meaning I can’t click it
(the CPU/ABI drop down list also has no options)
I feel I should mention that I couldn’t find a download link for the SDK on the android studio website. So I googled and found one which I downloaded. I’m not sure if that could be the problem. The name of the file I downloaded was tools_r25.2.3-windows.zip.
I can’t find the SDK manager .exe file anywhere, but in eclipse the SDK manager works fine (although sometimes I get an error and have to launch it a second time).

If u can help with links to a legit version of the SDK that would be great. I heard ADT isn’t supported anymore either. I is there another way to get it or do I have to do without?

Basically I’m looking for up to date help on how I can begin developing android apps using eclipse ide. I’m currently using a 64 bit HP stream laptop with 30 GB of memory and 2GB of RAM. So android Studio is not an option as the minimum is 3GB of RAM (unless maybe I can use an older version?).
I’m using the jdk 1.8. I heard that u can’t use after 1.6 to compile android code. can I set eclipse to compile for 1.5 or 1.6 in preferences and still use jdk 1.8? or do I have to download another jre.?
This is basically the last step I before I can start coding my apps. I’ve only been coding for about 3 months now but I’m already comfortable with eclipse and would like to continue using it. So any help is GREATLY appreciated!!


#2

Sounds like you don’t have the SDK installed. Try following the instructions on this page for your specific OS: http://www.androidcentral.com/installing-android-sdk-windows-mac-and-linux-tutorial

Also, make sure that your installations of Eclipse, the Android SDK, and the Java JDK are all the same “bit” version—i.e., they’re all either 32-bit, or 64-bit. You shouldn’t mix and match 32-bit with 64-bit.

Btw, you really need a computer upgrade. :stuck_out_tongue: Seriously only 2GB of RAM and a 30GB hard drive? You could easily get a new laptop in 2017 with much better specs than that for less than $300. Even ultra-budget laptops nowadays have at least 4GB of RAM and 320GB+ hard drives.


#3

Ok thanks. Do u think I should chance downloading android studio.?
What’s the worst and best case scenarios?

Lol. Yh that’s the plan. I had to do a major clean up just to get the SDK, java and eclipse
Unfortunately i have to make due for the moment :disappointed_relieved::disappointed_relieved:


#4

No, you don’t need Android Studio to get things working. When I first started learning Android development back in 2014, I used Eclipse just like you’re doing now, I think it was either the Kepler or Luna version.

When you do finally get a new computer though, you should definitely use Android Studio since Eclipse is no longer recommended for Android development.


#5

Also i haven’t downloaded any of the android API’s. I was thinking that was the problem…


#6

You only need to download a full API set if you don’t have a physical Android device for testing, whether a phone or tablet. And in that case, you would need to download a full API set so you can use the emulator (the System Images are for use with the emulator). Otherwise, you can get away with downloading just the SDK Platform for a given API. I’d recommend using API 15, as it’s a good balance between backwards compatibility and recency.

You should additionally install the Android SDK Tools, Platform-tools, and Build-tools under Tools, and everything under Extras, if you haven’t already.


#7

Thanks alot. I only have the android SDK tools(needs updating), android SDK platform-tools 25.0.3 and android SDK build-tools installed. That’s all I’ve installed from the SDK manager. Nothing from extras as yet and no API whatsoever. Could that be the problem.? I’m more interested in actually getting the project started in eclipse than the getting the AVD to work
Do I need an API or something from extras for the project to start.?
Also there are several older versions of the SDK build-tools. Should I install them or just the latest release.?


#8

The SDK is important, you won’t be able to work without it.
If you won’t have it, it will result in error for the IDE won’t know what your’e working with.
Other errors may occur also so you are going to need to fix those. If you are having troubles doing that you can use a software to help you, I know one called checkamrx you can try.
Good luck!
Michael.


#9

Make sure you have the right Eclipse packages installed for android development.
http://www.eclipse.org/downloads/packages/eclipse-android-developers-includes-incubating-components/neon2

Also, if you want to be able to use an emulator, make sure you have an intel processor with HAXM extensions. I bought a new laptop when I found out my core2duo was the last intel processor NOT to support virtualization. You can check in the BIOS screen for a virtualization setting (on or off), if it’s not there, it can’t be added because it’s hardware level on the cpu.
The best thing about installing android studio is that it installs all of the things you end up needing like ant and gradle.

I like Eclipse for Java, and lately Ruby with the dltk toolkit, but it seemed like way too much trouble to make it work and most of the android tutorials were written before there was an android studio.y


#10

OK. I’m using eclipse java neon right now
Is it possible to have more than one versions of eclipse on my machine.? Java and android.?
And does eclipse for android come with the SDK.? Or what’s the difference from java?


#11

Thanks for clarifying Micheal. I figured that might be the most likely problem…
I typed some android code into the java perspective since i couldn’t get the android project started and it was full of bugs I couldn’t fix


#12

The android tools sit beside Java in Eclipse. I have mars configured for Java and Ruby and an older version (Luna) that has just java and both work independent of one another.
I have not tried neon because I stick with android studio, but I might test it out once I get better at making android apps.
When I tried to get mars to work with android I had to specify the location of the JDK and android SDK in the settings.

I suggest installing android studio if it will let you just to put all the other parts in place, even if you have no intention of running android studio… then find out where it put everything and point Eclipse to all the required resources.


#13

That actually sounds like a good idea…
I only have limited access to the internet atm or I probably would’ve resolved it by now
I’ll try some of ur suggestions and let you kno how it goes


#14

Just wanted to thank everyone for their suggestions. .
I fixed the problem as of 2 days ago and everything is working fine now
Apparently the SDK package I was using was missing some components or they weren’t working properly as the android.batch file was giving an error every time I tried to launch SDK manager
Anyhow… I found a more recent version of the build tools in the temp folder(can’t remember where I got it from), and unzipped it to the correct location replacing the old version
Now I can code android apps :grin::grin:
Just have to figure out how to get the USB driver working for testing…
Thank everyone again for all ur help