Help with nesting an input step 15

Tell us what’s happening:
Describe your issue in detail here.

   **Your code so far**
/* file: index.html */
<!DOCTYPE html>
<html>
 <head>
   <title>Registration Form</title>
	  <link rel="stylesheet" href="styles.css" />
 </head>
 <body>
   <h1>Registration Form</h1>
   <p>Please fill out this form with the required information</p>
   <form action='https://register-demo.freecodecamp.org'>
    <fieldset>
<label>Enter Your First Name: <input type="text" required /></label>
      <label>Enter Your Last Name: <input type="text" required /></label>
      <label>Enter Your Email: <input type="email" required /></label>
      <label>Create a New Password: <input type="password" pattern="[a-z0-5]{8,}" required /></label>
       
     </fieldset>
     <fieldset></fieldset>
     <fieldset></fieldset>
   </form>
 </body>
</html>
/* file: styles.css */
body {
 width: 100%;
 height: 100vh;
 margin: 0;
 background-color: #1b1b32;
	color: #f5f6f7;
}

label {
	display: block;
	margin: 0.5rem 0;
}

   **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Step 15

Link to the challenge:

You need to include the <input></input> after each text inside the label element.
For example, you have this:

<label>TEXT: </label>

After the : you put a space and the <input></input> right before the </label>

input is a self closing tag and i tried it, didn’t work

This is interesting, I have the challenge exactly as I told you and it passed.
But I change to self-closing <input /> and it also passed!

See as example:
<label>Enter Your First Name: <input /></label>

I’m having the same issue. I even tried skipping to step 16 then copy and pasting exactly as it started out. No-Go. This seems to be a bug for sure. My browser: Firefox 101.0.1 (64-bit) Windows 10 x64

But what do you have there, @eltron247 ?
Can you paste your code?

<fieldset>
        <label>Enter Your First Name: <input /></label>
        <label>Enter Your Last Name: <input /></label>
        <label>Enter Your Email: <input /></label>
        <label>Create a New Password: <input /></label>
      </fieldset>

It seems your third and fourth input is missing the type.
For the third, the email, should be <input type="email"/>.
For the last one is the same idea except that there you have the password.

Its not asking for those in this instance yet. However, adding them does not fix the issue either.

Sorry for the late answer. When I posted that was working.
Now, trying your solution seems to work.
Maybe was a bug?