Heroku app help

My heroku app is a react app. I am running into an issue of invalid host header.
the first thing i tried to do was make a .env.development folder but i may have set it up wrong. If anyone has any suggestions please let me know. The repo is on github at https://github.com/syne612/projectIcarusWebsite if anyone has any suggestions please let me know.

Are you able to build and run your application locally? If not, I suggest that you make that happen first.

I wasn’t able to solve all your problems, but I found a few things that might help.

First, two of your npm packages are from builds that are currently in a Failing state. See https://travis-ci.org/michaelwayman/node-sass-chokidar and https://travis-ci.org/mysticatea/npm-run-all
These were my first (but far from last) obstacle preventing me from building or running your app.

Next, you have an error caused by a missing parenthesis in server.js on line 19.
I also saw various opportunities to maybe improve server.js. See my proposed changes at https://github.com/Trainosaur/projectIcarusWebsite/commit/0542532817c9ffbda8ad1801d270a816ac6f78d9?diff=split

In src/index.js, I believe line 6 should be changed to:

import indexRoutes from './routes/index.jsx';

And then a couple of suggestions that won’t save your app. Please create a file named .gitignore in the root directory and inside that file write:


And delete that directory from the github repo. Nobody wants that included when they download or clone your repo, and IIRC, Heroku uses package.json when your app is deployed, so you don’t need node_modules except in your local instance.

The other thing is, I haven’t used files with .jsx extensions in years and I’m not sure but I think it’s a problem in your app. I think it would be a good idea to get away from .jsx and just stick to .js. I may be ignorant about this issue, so don’t just take my word for it.

That’s all I have for you. Remember to try to get it running on localhost first. And here’s my (also not working) fork: https://github.com/Trainosaur/projectIcarusWebsite
The End.

so the app was working fine on my local host. the changes made recently have stoped it from working but the error i keep getting is can not fine a server to link up to. so if you delete the .env.development file it should run fine again. Also the server file needs work and it doesnt actually link up to the react app as of now. The entry point of the app is index.js .

Hey if you recheck my github you will see that it is now working fine on localhost. please retry. Still running into issues but it is not incorrect host header anymore.
I hadnt realized but i had not pushed all the invisible “.” files.

Its ok, jsx files are working you can keep it

?? what do you mean? also any clue why it could be still not running.