Heroku installation problem on window

Heroku installation problem on window
0.0 0

#1

Im working on the API project, i installed hero toolkit in the main website some how after installation i tried to run any command line relate to heroku and it said ro me bash is not recognized as an internal or external command. Can any one help me to solve it??


#2

From the error it’s clear that Bash cannot find the heroku command, it’s not on your PATH.

Do this from your cmd

echo %PATH% // path of heroku bin 
set PATH="C:\Program Files\Heroku\bin;%PATH%" 

#3

I did it like you said now it couldnt reconigzw any npm command​:joy::joy:


#4

I assume it’s just because you don’t set the path properly. Add the path in your environment.


#5

I did like what you say when i installed heroku toolkit but some how it still failed i dont know why but a lot of people has met this situation. I couldnt finish this challenge if i cant deploy it in heroku


#6

Well I understand your situation. Anyway would you tell me which challenge are you trying ? So that I could understand what’s the real issue is :slight_smile:


#7

im working on the timestamp microservice but the problem is i finished it and i try to deploy it through heroku to complete the challenge but since i couldnt use hero command to login pr deploy its a pain now


#8

Do you use heroku from git bash ? or from command prompt ?


#9

I used command prompt