Tell us what’s happening:
I tried the code running a local server and when I go to the route (i.e. localhost:3000/json) it works as intended
but if I enter the link to the challenge input the tests dont pass

I tried the same with a glitch link with no luck

is the test broken?

Your code so far


/json handler

app.get("/json", (req, res) => {
  var message = "Hello json"
  var uppercase = process.env.MESSAGE_STYLE === 'uppercase'

    message: uppercase ? message.toUpperCase() : message

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36.

Challenge: undefined

Link to the challenge:

Did you get a solution to this @champi-dev ? I’m also stuck.

Welcome, derrick.

I recommend you open a topic of your own, for this - being sure to provide us with a link to your project.

Keep in mind: For the last few weeks, Glitch has been having stability issues, and many tests are failing, as a result.

1 Like

Welcome, champi-dev.

Sorry, we missed this topic. Have you managed to get this problem resolved?

Thank you for the pointers, Glitch has been having issues…But this one was my mistake, I failed to comment earlier code or remove a line of code from an earlier challenge.