I have a problem

at the lesson " Basic HTML and HTML5: Add a Submit Button to a Form" whatever i do its wrong
i looked on youtube andd i get the solution but on may pc thats wrong
maybe its a bug
i want to resolve it
pls help

Hey cool that you want to help
but may i suggest to leave us a link to the challenge

and post your code instead of a screenshot?

the html item botton doesn’t exist, but it could not be the only issue, and in that case, and in general posting your code instead of a screenshot will mean you get better help, as it is easier for people to debug your code

you can just use the Ask For Help button next time, and that will do the trick with no extra effort on your part - but writing the “tell us what’s happening” part would really be important to get better help

https://learn.freecodecamp.org/responsive-web-design/basic-html-and-html5/add-a-submit-button-to-a-form/

<h2>CatPhotoApp</h2>
<main>
  <p>Click here to view more <a href="#">cat photos</a>.</p>
  
  <a href="#"><img src="https://bit.ly/fcc-relaxing-cat" alt="A cute orange cat lying on its back."></a>
  
  <p>Things cats love:</p>
  <ul>
    <li>cat nip</li>
    <li>laser pointers</li>
    <li>lasagna</li>
  </ul>
  <p>Top 3 things cats hate:</p>
  <ol>
    <li>flea treatment</li>
    <li>thunder</li>
    <li>other cats</li>
  </ol>
  <form action="/submit-cat-photo">
    <input type="text" placeholder="cat photo URL">     <botton type="submit">Submit</botton>
  </form>
</main>

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.

markdown_Forums

when i run ure code i get the next error:

Your form should have a button inside it.

Your submit button should have the attribute type set to submit.

Your submit button should only have the text “Submit”.

Make sure your button element has a closing tag.

i’m new here :slight_smile:

don’t worry the mods are just here to help u do it easier not punish u :3 welcome to the community btw

welcome to the forum!

the botton html element is not a thing, it doesn’t exist

the botton html element is not a thing, it doesn’t exist what that means?

it means that the botton html tag you have used in your code will never work as it is not a valid thing

it means this part of ure code

<botton type="submit">Submit</botton>

how can i fix it? i want to go over to next lesson

Instead of Firefox, try using Google Chrome, and maybe you’ll pass.

i’ll try to change the browser

have u tried deleting it? no worry’s u can just reset the code out copy past it from here :3

it doesn’t work any ideeas?

yes they give u an example right?

<button type="submit">this button submits the form</button>

then they say: “Submit” as its text.

it doesn’t work ! what else can i do