I keep getting this error message:'react-router' does not contain an export named 'browserHistory'. any solutions?

I keep getting this error message:'react-router' does not contain an export named 'browserHistory'. any solutions?
0

#1

I keep getting this error message:‘react-router’ does not contain an export named ‘browserHistory’. any solutions?


#2

I solved the issue by installing v3 like this: npm install react-router@3 --save


#3

In v4 You would need to import BrowserRouter from ‘react-router-dom’. If you’re creating something new, it’s probably a good idea to try to use the latest version.