"invalid regular expression flag s"

I get this message in the console:
“SyntaxError: invalid regular expression flag s”,
how can I fix this error?.

1 Like

Welcome, Amlal.

Would you mind opening up the browser console, and sharing any errors?

Also, try hard-refreshing the page, and disabling any adblocker extensions.

1 Like

I get the same error message in the browser console.

is there just that line? or there are more details there?

Just that line.
The same error even for the previous challenges I passed.
I log out and log in to my account, refresh the page, change browsers but I still get the same error.

can you try to update your browser(s)?

it’s a few days that this error keeps happening, and this is a thing that seems to have worked

also, could you please open a bug report?

Thank you for helping make FCC better. Bugs can be reported as GitHub Issues. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.

1 Like

Problem solved .
Thank you . :+1:

hello Amlal
what did you do exactly? I update browser it doesn’t work for me

Hi Mohamed.
Which browser do you use ?
I was using Firefox browser until this problem appears ,I updated it but it didn’t work.Then I installed chrome browser and it works.