Issue running pnpm run seed

I’m getting the error below when trying to run pnpm run seed I followed the guide to start contributing and this is the step I’m stuck in. Has anyone run into this issue before?

Unfortunately, I haven’t run into this issue before but maybe someone else has.

Do you have the mongo service running?
The error message seem to keep pointing to an issue with the connection string.
maybe you can try stopping the service and starting it again.

hope that helps

Yep, mongo is running, tried restarting it and it still didnt work.

hmmm… ok

I tried searching the forum for similar issues but wasn’t able to find any.
Hopefully someone else will chime if they have run into that issue.

But what kind of contribution were you looking to make?

Because depending on the type of contribution you are doing for freeCodeCamp, you could technically work on some of the open help wanted issues while having the mongo server running and your local dev environment running with pnpm run develop.

If the type of contribution you are working requires you to be signed in, then you will need to wait to hear back from other contributors about possible fixes.

But if you are looking to update some of the tests for project challenges, then you should be able to test everything with just having a running mongo and localhost working

Any contribution, if you can point on what have more priority and I could try helping there. Ill try again tomorrow and see what I can run or not run.

Any of these would be good to start with.
As long as you can run it locally, then you don’t need to be signed in to work on these issues.

All of these issues involve updating the directions to make them more clear

this one involves adding some missing tests

Using Gitpod is always an option.


I think when you do the setup it should copy the sample.env to .env but maybe check if you have the .env file in your root folder. If not, create it and copy the content from the sample file into it.

https://github.com/freeCodeCamp/freeCodeCamp/blob/main/tools/scripts/seed/seed-surveys.js

1 Like

I forgot to add the dot in front of “env” :sweat_smile: Thanks for your help, now I’m up and running

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.