I've installed Java jdk 13 on my computer , but when I typed java -version in my command prompt its still showing java 10

I’ve installed put my java jdk 13 file in the proper path file on environmental variables tag but my computer doesn’t recognize jdk 13. Also, I have no idea where jdk 10 is because it doesn’t show up in the environment variables part. I think maybe I need to deleted jdk 10.

You are seeing the runtime version, try javac -version (not a Java dev BTW). Unless you need older versions (runtime or jdk) I’d suggest uninstalling the older versions.

how do you uninstall the older versions? How do you find out where the older versions are on your computere?

Just go to the Control Panel and look at the list under Programs and Features

Uninstall or remove apps and programs

Uninstall from the Control Panel (for programs)

  1. In the search box on the taskbar, type Control Panel and select it from the results.

  2. Select Programs > Programs and Features.

  3. Press and hold (or right-click) on the program you want to remove and select Uninstall or Uninstall/Change. Then follow the directions on the screen.

BTW, newer installs (of at least the runtime) will give you an option to uninstall older versions when installing a new version.

that command works when I typed javac -version on my cmd prompt as an adminsitrator:

and it does work on my regular command prompt:

But when I attempt to run a javafx application on an intellij ide, intellij doesn’t recognize my javafx commands when I run my application using jdk13:

But it does work for JDK9 :

I tried changing the project language level to 13 but thats not listed as an option

I want to use JDK 13 because JDK 13 has the var variable now and I need the var variable for a project

Don’t know. Try checking the paths for the SDK or setting up a new SDK and add the correct paths.

https://www.jetbrains.com/help/idea/sdk.html