Learn Basic CSS by Building a Cafe Menu - Step 2

**Tell us what’s happening:

The step I’m on just says add a head tag and a title tag within it. But somehow with the below
Which I’ve double checked 10000X was right from other websites the “check code” is saying “you need to add a head opening gtag.

Your code so far

<!DOCTYPE html>
<html lang="en">
<head> 
<title>Cafe Menu</title>
</head>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (iPhone; CPU iPhone OS 15_6_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.6.1 Mobile/15E148 Safari/604.1

Challenge: Learn Basic CSS by Building a Cafe Menu - Step 2

Link to the challenge:

Oh dear! It looks good though.
What browser are you using?

1 Like

Safari, I tried on my chrome as well didn’t work. And I checked my extensions and disabled them all. :slightly_frowning_face:

1 Like

I am not sure why it is not letting you pass. One thing to try is to go to step 3 and see if it behaves better or not. If not, then it might be something in your environment.
Another idea is to download a different (new) browser, for eg Opera and try there.

You’re on a mobile phone correct?

Yeah, the latest Iphone.
I can download another browser. Just weird because all of the lessons up to this point were fine. (Like the Cat Website project).

I’ll download opera and see if it works

Have you tried chrome-based browser?

I am on iPhone 13 too but I can pass the step on chrome.

Yeah same problem.
I just skipped to the next step and same thing!
I just did like 90 steps on the Cat Website project no problem.

Okay another check:

Can you go back to the cat project and do the very first easiest step after restarting it?
If it fails there, maybe something new got installed on the phone … or maybe not.
Try first.

Oh wait!
In your last screen shot you have an extra space in the meta tag.
(Just before the equals)
Can you fix it and see if step 3 will pass?

Cat project step one worked

1 Like

In step 3 that you tried the meta tag had an extra space before the equal sign. Can you fix it and check the code?

1 Like

Wow that worked.

Okay so something weird is going on with step 2.

Can you simply reset the step then do not type anything in. Just reset it.

Then try shutting the browser down (get the app to close entirely)

Then go back into fcc and type only one thing.

Just the head element alone (opening tag and closing tag only).

Then click check your code.

It should fail but I want to know what it says.

Alright, did that and got this

That does not look promising.

Edit: I will check github to see if anyone reported a similar issue

1 Like

Lol. That’s one way of putting it. :joy:
Hopefully I can just continue on and there no more problems. I just hope it lets me pass the project since I can get a pass step 2

Yes the project has nothing to do with the steps (you can skip the steps and just do the projects if you know html/css)

Ooh, that’s good to know. Awesome. Okay, we’ll I’ll just continue then and hopefully all is well.

Thank you very much for the help!