Learn Basic JavaScript by Building a Role Playing Game - Step 19

Tell us what’s happening:

I’m not sure why the code is not passing. I keep getting “Your #monsterStats element should have two span elements.” To my knowledge it is correct and has two span elements. i have tried different browsers and i have 0 extensions so I’m stuck and cant move on. Please help! Thanks

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <link rel="stylesheet" href="./styles.css">
    <title>RPG - Dragon Repeller</title>
  </head>
  <body>
    <div id="game">
      <div id="stats">
        <span class="stat">XP: <strong><span id="xpText">0</span></strong></span>
        <span class="stat">Health: <strong><span id="healthText">100</span></strong></span>
        <span class="stat">Gold: <strong><span id="goldText">50</span></strong></span>
      </div>
      <div id="controls">
        <button id="button1">Go to store</button>
        <button id="button2">Go to cave</button>
        <button id="button3">Fight dragon</button>
      </div>

<!-- User Editable Region -->

      <div id="monsterStats">
<span class="stat">Monster Name: <strong><span id="monsterName"></span></stong></span>
        <span class="stat">Health: <strong><span id="monsterHealth"></span></stong></span>
      </div>

<!-- User Editable Region -->

      <div id="text"></div>
    </div>
    <script src="./script.js"></script>
  </body>
</html>
/* file: script.js */
let xp = 0;
let health = 100;
let gold = 50;
let currentWeaponIndex = 0;
let fighting;
let monsterHealth;
let inventory = ["stick"];

const button1 = document.querySelector("#button1");
const button2 = document.querySelector("#button2");
const button3 = document.querySelector("#button3");

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/125.0.0.0 Safari/537.36

Challenge Information:

Learn Basic JavaScript by Building a Role Playing Game - Step 19

this typo is causing issues with the html

1 Like

There are typo in your code.

1 Like

Thanks everyone for the help! it makes sense now lol