Learn CSS Colors by Building a Set of Colored Markers - Step 49

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**
/* file: index.html */
<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <title>Colored Markers</title>
  <link rel="stylesheet" href="styles.css">
</head>
<body>
  <h1>CSS Color Markers</h1>
  <div class="container">
    <div class="marker red">
    </div>
    <div class="marker green">
    </div>
    <div class="marker blue">
    </div>
  </div>
</body>
</html>
/* file: styles.css */
h1 {
text-align: center;
}

.container {
background-color: rgb(255, 255, 255);
padding: 10px 0;
}

.marker {
width: 200px;
height: 25px;
margin: 10px auto;
}

.red {
background: rgb(255, 0, 0);
}

.green {
background-color: #007F00;
}

.blue {
background-color: hsl(240, 100%, 50%);
}

  **Your browser information:**

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.4 Safari/605.1.15

Challenge: Learn CSS Colors by Building a Set of Colored Markers - Step 49

Link to the challenge:

Hey,
Could you specify what is your issue?

I am attaching the screenshot here. The instruction says “ In the .red CSS rule, change the background-color property to background .” And I did that but I still don’t pass. Please help advise :slight_smile:

Hi @rakvit.tin ,

Your code passes for me. Can you try a different browser ?

Or maybe you should look at this :

Thank you so much Dario! This frustrated me so much last night :confused:
What browser do you think is best?

1 Like

I am not sure.
But I am using Chome and I’ve never had similar issues with the tests. I am also using Windows.

FYI - I am re-doing step 49. First, I tried it on Chrome, the code did not pass. I then downloaded Microsoft Edge - the code didn’t pass either. (Screenshots attached). This is worrying me.


Same error with Microsoft Edge.

Hi @rakvit.tin

I did try and your solution works for me. check below.

Probably it is not working for you because of the device or the theme you are using. Try changing to light theme if possible and resubmit. If it still doesn’t work, consider moving to the next step like someone suggested above.

1 Like

It works for me too. I was asking to specify for this reason @rakvit.tin

As mentioned earlier :

This seems to be a problem with old apple devices.