Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:

Can someone help with this? From all my research I believe I have the code correct but it keeps saying it is not. Can anyone explain what the issue is? I keep receiving this error Your anchor (a ) element should link to https://freecatphotoapp.com . You have either omitted the URL or have a typo.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

      <a href"https://freecatphotoapp.com><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 15

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.
Learning to describe problems is hard, but it is an important part of learning how to code.
Also, the more you say, the more we can help!

Okay the first big issue I see is that you forgot the = that allows you to properly set the attribute on the html element. Next you forgot the end quotes.

Here’s what an a element should roughly look like.

<a href="https://www.freecodecamp.org">FreeCodeCamp</a> 

The href attribute is set to https://www.freecodecamp.org.

Let me know if you need any extra help.

Happy learning. :slight_smile:

2 Likes

Omg thank you! That’s great!

1 Like