Learn HTML by Building a Cat Photo App - Step 21

Tell us what’s happening:
Describe your issue in detail here.
Please help me, I have spent more than hour trying to figure out where to add the ;;<img; img i continue getting the same error “There should be an img element right after the closing </ul> tag.”

when i change the error is " The new image does not have an alt attribute. Check that there is a space after the opening tag’s name and/or there are spaces before all attribute names."

  **Your code so far**
<html>
<body>
  <h1>CatPhotoApp</h1>
  <main>
    <section>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
      <a href="https://freecatphotoapp.com"> <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
    </section>
    <section>
      <h2>Cat Lists</h2>
      <h3>Things cats love:</h3>
      <ul>
        <li>cat nip</li>
        <li>laser pointers</li>
        <li>lasagna</li> <img 
         src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagana on a plate."> </ul>
      
    </section>
  </main>
</body>
</html>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 21

Link to the challenge:

Img should be AFTER closing ul tag.

Your img is before closing ul tag

1 Like

Thank you for the response, i have tried all options. error keeps on coming

You changed the code? Tests are still failing?
Then post your new code here.
To make code look like

this

press ctrl-e when writing post

  • cat nip
  • laser pointers
  • lasagna
  • A slice of lasagana on a plate.

Well, that’s not code yet)
Try to edit your last post.
Press ctrl-e.

You will see triple backticks. Move your code between them.

some issues with editing post? feel free ask more questions. We really need to see your new code to move on

type or paste code here<ul>
          <li>cat nip</li>
          <li>laser pointers</li>
          <li>lasagna</li> <img 
           src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagana on a plate."> </ul></img>

Ok.
img is self-closing element.
so this:

is something incorrect.

Also your whole img element should be after ul element

And this stuff:

You could delete and it would be perfect)