Learn HTML by Building a Cat Photo App - Step 56

I am stuck on step 56:

I kept trying and unable to get those correct even I checked the previous forum for answer. It is still not correct.

My code:
<input id="loving"type=“checkbox”> Loving

Please help

Challenge: Learn HTML by Building a Cat Photo App - Step 56

From what you gave us above, it doesn’t look like you have made any changes to the original HTML. Do you have a specific question about this step? Please try again and then paste your updated code in here if it doesn’t pass so we can see what you did.

It’s better not to post pics of code and instead paste the code in here using the triple back tick method. To display your code in here you need to wrap it in triple back ticks. On a line by itself type three back ticks. Then on the first line below the three back ticks paste in your code. Then below your code on a new line type three more back ticks. The back tick on my keyboard is in the upper left just above the Tab key and below the Esc key. You may also be able to use Ctrl+e to automatically give you the triple back ticks while you are typing in the this editor and the cursor is on a line by itself. Alternatively, with the cursor on a line by itself, you can use the </> button above the editor to add the triple back ticks.

(post deleted by author)

(post deleted by author)

<input id="loving" type="checkbox"> <label for="loving">Loving</label>
1 Like

And how did that work out for you?

It does not work. I get the hint stating - you will need to add a new label element in which to nest the text Loving. Make sure it has both an opening and closing tag.

Perhaps you accidentally made a change somewhere else that you shouldn’t have made and thus the tests are failing? You might try restarting the step and then add your new code again being very careful not to change anything else. Or you can post all of your HTML in here so we can see if there are any unnecessary changes.

Hello bbsmooth. Thank you for your response. I have just double checked. For step 56, all my previous codes were gone. However, if I click on previous steps or steps after 56. All the previous codes were there.

I tried logging out of my account and logging back in and it stays the same. How can I fix that?

It sounds like you might be experiencing this bug? Just move on to the next step. From the code you pasted above you have done it correctly. You can skip steps and still get the certification at the end.

ok. Sounds good. Will this bug affecting my steps afterwards and do I need to fix that somehow?

No, skipping a step will not affect your ability to complete the latter steps.


Here is what I inserted into the code. I hope this helps. This problem was marked as passed.

Make sure why there must be a space after tag and before tag. That only made the code work. You can rather use or press ‘Enter’ after tag and then start with tag to make it work.

Mod edit: removed solution

It is great that you solved the challenge, but instead of posting your full working solution, it is best to stay focused on answering the original poster’s question(s) and help guide them with hints and suggestions to solve their own issues with the challenge.

We are trying to cut back on the number of spoiler solutions found on the forum and instead focus on helping other campers with their questions and definitely not posting full working solutions.