Learn HTML Forms By Building A Registration Form Last Step (57)

Hey guys,

When I enter this CSS code, an error message appears, saying "
You should use an “a " element selector. I am at a loss as to my knowledge, I have done just that. I have tried using a space between the bracket and the a selector, two spaces, no spaces, even putting a period before the a like a class selector and the same error message keeps popping up:”

You should use an a element selector."

Am I missing something obvious? This is REALLY frustrating as it seems like a simple last step and the error message is maddening.

a {
color: #dfdfe2;

it looks fine to me ,if you can add the link to the chalenge maybe it will be easier to fix

I don’t know if it will show you all of my progress since I have to login in order to complete the course, but here it is:

It looks like when I link the step I’m on, it may just redirect you to the main site. I am on the first certification (New) Responsive Web Design Certification (300 hours), then the third course, which is the title of the thread, then on the last step.

looks fine
refresh the page and do it again

when asking for help a helpful thing to do is to check your code multiple times and when it asks if you need help to press. That way we can see your code and get a link to your lesson

i tried this and it passed

I have both:
Checked my code multiple times

Pressed the button to ask for help

When I press the help button, it wanted me to make an account for these forums, then it set me to the homepage. So that is why I copy and pasted the code.

When I refresh (F5), the old code I had reappears on the line, unlike all of the other lessons, which clears the code. I believe there used to also be a button to click to refresh the code a try again, but it’s nowhere to be found. I think there just may be a bug on the last lesson :confused:

I copy and pasted the code in verbatim and it did not pass, even though it seems correct.

reset the chalenge maybe there’s a mistake somewhere else

Nevermind the activate Windows, that’s another problem lol. Upgraded from 8 to 10, then to 11, and changed hardware, now it needs registered even though I can’t find the original Windows 8 disc I had.

Regarding the challenge, like I said, there used to be a reset button and it seems to be gone, I think there was a button at the top to restart the lesson on the other steps, but not this one for some reason. I might try clearing history, cookies, etc, then re-installing chrome and see what that does. I think the lesson itself is buggy.

I spammed the button a bunch of times and the button to restart the lesson finally appeared below the “check code” button. I still have no idea what’s wrong with my code as it still keeps saying to use the “a” selector

Alright guys nevermind, when the button finally reappeared and I retyped the code, I forgot the colon after the property, and the semi-colon after the value. It is working now and I am finally onto the project at the end. Thank you guys so much though for the help. I think when I had it typed out correctly the first time, it was just buggy.

i just copied your code and it works for me!

1 Like

Yes, it works…it makes since. I thought I could use the name inout, cause I set it to terms. However you are actually referencing the <a href input :

terms and conditions

In the HTML file to change the color of terms and conditions to white. I was confused as well on this step lol may still be :joy:

resetting worked for me and the code was right

a {
color: #dfdfe2;

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.