Learn HTML Forms by Building a Registration Form - Step 18

For Step 18, I followed the prompt:

" Following accessibility best practices, link the input elements and the label elements together using the for attribute. Use first-name, last-name, email, and new-password as values for the respective id attributes."

I linked the two attributes together using ‘for’ and ‘id’ with the proper respective names. But, my code will not pass. I keep getting the error: " The first input element should have an id of first-name"–however, it does.

What am I missing?

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
    <meta charset="UTF-8">
    <title>Registration Form</title>
    <link rel="stylesheet" href="styles.css" />
    <h1>Registration Form</h1>
    <p>Please fill out this form with the required information</p>
    <form method="post" action='https://register-demo.freecodecamp.org'>

        <label for="first-name">Enter Your First Name: <input id="first-name"></label>
        <label for="last-name">Enter Your Last Name: <input id="last-name"></label>
        <label for="email">Enter Your Email: <input id="email"></label>
        <label for="new-password">Create a New Password: <input id="new-password"></label>

/* --- STOPS HERE --- */

/* file: styles.css */
body {
  width: 100%;
  height: 100vh;
  margin: 0;
  background-color: #1b1b32;
  color: #f5f6f7;

label {
  display: block;
  margin: 0.5rem 0;

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:107.0) Gecko/20100101 Firefox/107.0

Challenge: Learn HTML Forms by Building a Registration Form - Step 18

Link to the challenge:

Edit: Now it is passing again. That is really weird, but it seems to passing again when I use the code you have provided. I would still suggest restarting the lesson and putting back in the code you have now and see if you still get a failing error

Thank you for your response, @Cody_Biggs! I restarted the lesson and kept getting the same error. So, I figured it was a browser issue. And voila! I switched from Firefox to Google Chrome and the solution passed! :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.