Learn SQL by Building a Student Database: Part 1 - Build a Student Database: Part 1

I’ve tried many things but my bash script just won’t run. I’ve tried resetting the code, soft reset, signing in and out- nothing works.
When I enter this into the terminal:
nothing happens. What to do?

After you typed the line, did you click enter?

Did the script run?
(I cannot tell from the screenshot you have if the script ran or not)

Hi! Yeah, I did hit Enter (I’ve done it about a hundred times.) It never shows any signs of running, but just returns a new line. Here’s a screenshot:

does the Reset button do much here?

Nah- tried it twice out of desperation, in case I was missing a comma or something

i’m trying to work my way thru the steps to get to the point you’re at but I think I’m still quite a few steps away (I just finished adding the top comment to the sh file).

Since I can’t do this tonight, i will suggest that you try commenting out a few lines of code in your .sh file and re-running. (basically comment out the last line you added, then re-run just to see if you can get the sh to do anything at all).
Or you can add some echo statements here and there (or everywhere) to see how much of the sh script is getting executed if anything.

Hi Thanks for your help. I have tried to get anything to run from the .sh and nothing works. I’ve also tried on multiple browsers.

Can you paste the code here in full (including all the echo statements you added to it to try to see if anything works?)

1 Like

I don’t think it was my code- I had reset it a number of times. This thing is pretty buggy so I just decided to start over, deleted the lesson from CodeAlly, and it just accepted it.

@ hbar1st
Thank you for all your help!