haven’t been able to access the tutorial for about 2 days no and now i receive this wacky message
codeally@5f7f04c7f136:~/project$ psql --username=freecodecamp --dbname=postgres
psql: error: connection to server on socket “/var/run/postgresql/.s.PGSQL.5432” failed: No such file or directory
Is the server running locally and accepting connections on that socket?

and no it’s not my computer or web browser because I get the same results on different computers and differet networks. i should also mention that in order to pass any section of this tutorial, i had to display all the databases regardless of what the actual task was. pretty sure i could have just typed “your mom” and as long as i type “\l” it was going to pass me. i’m really good at listing all the databases now…well when i coudl actually acesss the material.

I started getting the same error two days ago. I tried so many different solutions. Letting you know you aren’t the only one, so it isn’t something with you computer. I wish we could get an answer to this.

Try to do the projects locally, you can use WSL to have a linux VM in which you have bash, git, a you install PSQL and build you own database there. That’s what I did. And I feel your pain, CodeAlly rarely works like a charm and I remember my progression not saving when it reached 100%.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.