Link to External Pages with Anchor Elements with two sets of instructions

Tell us what’s happening:
I seem to have added the anchor words and link in my element,

but there are two requests being made of me, one is with wbr and the other is not,

on my sample it appears that I have done the lesson correctly,

but IDK,

it will not let me pass,

can you point out where I am incorrect please?

Your code so far
I am too new so I cannot have links

What is your solution? What do the failing tests say?

You still need to post your code, otherwise it is not possible to see what you are talking about

In the lesson I have to create an element with a link to catphotosapp dot com, but the test results say I need an element with a link to catphotosapp wbr dot com

I cannot post it because I am new and they will not let me post links

Put spaces inside the links, but if you don’t post your code we can’t see

You could even post a screenshot

I cannot post the code because I am a newbie

but my lesson has me inserting a link with anchor words, all good, then the test results keep insisting that I do not have the link in the element, which I clearly do, so I guess I will start the lesson again

Without your code it is not possible to help

There is no restriction preventing you from posting code when you’re new. Without seeing what you have tried, we can’t really help you fix it.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.


There is also a restriction from preventing me from posting code with a link in it, because when I try to post it here, I get a message saying I am too new to post links yet.

I will try the screen shot for you.

On the left it says to create a link with anchor words, so after I do so the test results say, I need to provide a link but with a wbr added to it

My confusion is that it seems they are asking for two different links

Reread the instructions slowly and carefully. It tells you that the anchor element has two parts; a web address and anchor text. It then gives an example showing and explaining what part is the web address and what part is the anchor text.

Knowing that, you provided an answer but the big X is telling you that your anchor element does not have a link to
What does your link look like? Look at your link carefully and look at the link they want…again, look carefully.
Hint: There is a difference.

Btw, I just noticed the <wbr>. Ignore that

1 Like

Thank you Roma, I did retry http instead of https and now it works, and I have advanced in my lesson, and thank you for acknowledging the wbr, that really threw me through a loop.

@newbiedouglas Glad to help.

When you have some time use Google to see what the differences are between the two protocols http and https

Also, do a Google search on ‘HTML wbr’ to see what the wbr element is. Although I can’t say why it’s in that example.

I opened an issue, but I should just make a PR for this. There is no reason why the challenge is mixing protocols like that. The protocol shown in the challenge text should be the same as required by the test.

The <wbr> tag in the message is fixed (PR), it is just not on the main site. You can check out the challenge on the FCC beta version which has the fix.

BTW, don’t use the beta version for your main progress in the curriculum.

1 Like