Make Screen Reader Navigation Easier with the footer Landmark: Issues with div

Tell us what’s happening:
It says that I’m supposed to take out all div elements, but there are none. Is there an error, or am I missing something?

Your code so far

        <li><a href="#stealth">Stealth &amp; Agility</a></li>
        <li><a href="#combat">Combat</a></li>
        <li><a href="#weapons">Weapons</a></li>
    <section id="stealth">
      <h2>Stealth &amp; Agility Training</h2>
      <article><h3>Climb foliage quickly using a minimum spanning tree approach</h3></article>
      <article><h3>No training is NP-complete without parkour</h3></article>
    <section id="combat">
      <h2>Combat Training</h2>
      <article><h3>Dispatch multiple enemies with multithreaded tactics</h3></article>
      <article><h3>Goodbye world: 5 proven ways to knock out an opponent</h3></article>
    <section id="weapons">
      <h2>Weapons Training</h2>
      <article><h3>Swords: the best tool to literally divide and conquer</h3></article>
      <article><h3>Breadth-first or depth-first in multi-weapon training?</h3></article>

  <footer>&copy; 2018 Camper Cat</footer>


Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36.

Link to the challenge:

have you changed anything else in the code? have you tried reloading the page? resetting code and trying again?

Yes I have. I’ve had this issue on this lesson, as well as the previous four lessons. I’ve reset the code multiple times, to no avail. The result is the same, where I need to remove the div tags

Hi @jjchri01, I’m not sure this helps at all, but the code you’ve pasted is actually the correct solution, so if you click on ‘Run the Tests’ it should pass. Here’s the weird thing: I’ve passed all these challenges but when I go back to them the code resets to the default (meaning, I would have to change it again to pass the test) except for this one, where somehow my solution was ‘saved’ and all I can see is the <footer>.

I’ve tried navigating to the challenge from the incognito mode and then I could see the <div> as normal.

So the only explanation I could think of is that if you’ve already passed this test before, it’s some sort of glitch.