Making image responsive

Tell us what’s happening:
I don’t know what I’m doing wrong. This was my original answer and when it shoed wrong I added the display: block;

max-width: 100%;
height: auto;

Your code so far

.responsive-img {
max-width: 100%;
display: block;
height: auto;

img {
width: 600px;

<img class="responsive-img" src="" alt="freeCodeCamp stickers set">
<img src="" alt="freeCodeCamp stickers set">

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18362.

Challenge: Make an Image Responsive

Link to the challenge:

Hi @Conradn I do not see anything wrong with your solution and when I try it pasting your code in the challenge, it’s good, it passes the tests.

So to understand and be able to help can I ask what is the problem that you are experiencing? Can you provide more insight? Did you try running the submission tests already?


Your code successfully passes the tests on my end. Please ensure your browser zoom is set to 100% and you have disabled any extensions that access FCC (such as dark mode).

I’ve run the test a few time. Logged off and on a few time as well and the error still shows.

Hmmm it looks like you’re using an old version of Microsoft Edge. I recommend updating to the latest version, as it now runs on Chromium and may work better for you.

1 Like

Adding to @nhcarrigan,

You can get the latest Chromium Edge here:

I can definitely vouch for this browser, because I’m using it every single day. So it works perfectly with the FCC curriculum.

1 Like

Thank you all. I’ll try it out as soon as I get home. I tried it on two different computers, but I’ll have to check if it’s the latest version of Microsoft edge. Thanks again everyone.