Mern + heroku causing api routes to go to static html page instead

Running Create-React-App + Express on local host all worked fine tried to deploy my first app today got it loading however all API requests now serve me a blank index.html page which would normally house my react page rather than the requests to Mongo Atlas.

really hoping someone else has had this problem as I’m stumped :frowning:


Could you provide more information, for example, the code? Also, what did you do to publish your app (the steps to reproduce the problem)?

You can use github or gitlab to publish the code and/or

hello thanks for the response here is the repo:

to publish it to heroku i used git “push master heroku”

and the scripts inside package.json at the time were(they may look diff in repo due to me trying stuff out, so far anything else I’ve found doesn’t compile for one reason or another) :

"scripts": {

    "start": "react-scripts start && nodemon server.js",

    "build": "react-scripts build",

    "test": "react-scripts test",

    "eject": "react-scripts eject",

    "install-client": "npm install",

    "heroku-postbuild": "npm run install-client && npm run build"