ModuleNotFoundError: No module named 'pandas'

Hi, I am working on Medical Data Visualizer Project. When I run my code, I received ModuleNotFoundError: No module named ‘pandas’ error. Right before I got this error, I got a flash of this error below:

I believe this has to do something with numpy version. So I followed few solutions from here but they were no good or I massively screwed up.

Also, this is what I figured; when I shuffled the module imports, the error was ModuleNotFoundError: No module named ‘seaborn’. This made everything even more confusing.

Solutions I tried:

  1. Changed the poetry.lock file:

[[package]]
category = “main”
description = “NumPy is the fundamental package for array computing with Python.”
name = “numpy”
optional = false
python-versions = “>=3.5” (I changed it to 3.8)
version = “1.17.4”

  1. Modifying .replit file:

deps = [
pkgs.python38Full
pkgs.python38Packages.matplotlib
pkgs.python38Packages.numpy
pkgs.python38Packages.pandas
pkgs.python38Packages.seaborn
];

  1. running pip install pandas on my terminal.

So I tried these 3 methods but I am still having the same issue. If someone can advise me on this, it will be much appreciated. Thanks in advance!

You can try it as well. Hopefully, it will work. Worked for me.
pip install wheel
pip install pandas

Do I need to run these command on my terminal?