MongoDB and Mongoose - Install and Set Up Mongoose1

Tell us what’s happening:
Test will not pass. cannot find mongoose and mongodb as dependencies and not connecting to the data base. Below are extracts of the code used

Your code so far

{
“name”: “fcc-learn-node-with-express”,
“version”: “0.1.0”,
“dependencies”: {
“express”: “^4.14.0”,
“body-parser”: “^1.15.2”,
“cookie-parser”: “^1.4.3”,
“fcc-express-bground”: “https://github.com/Em-Ant/fcc-express-bground-pkg.git”,
“mongoose”: “5.3.12”,
“mongodb”: “3.1.10”
}, …

mongoose.connect(process.env.MONGO_URI, { useNewUrlParser: true });

Link to the challenge:

I were able to solve the problem.

I have the same problem. How did you solve it?

@Damoness Please create a new topic for questions about your own challenge code. Also, please be specific about what problem you are having.