My progress has reset in CodeRoad

A few days ago I started with the “Relational Database” course, I successfully finished “Learn Bash by Building a Boilerplate” in a total of 3 days in which the progress was successfully saved in the interactive tutor “CodeRoad”. Later I continued with the course “Learn Relational Databases by Building a Mario Database” of which I did a few lessons, for three days I had not opened the course and when I opened it today my surprise is that all the progress has been restarted, both this course and the Previous, What could I do to recover the progress of both courses? :smiling_face_with_tear:


I have the same issue in gitpod for the mario database. Yesterday, when I went to pick up where I left off, the entire database I had created the day before was gone (35% ish through the tutorial), but I was able to click the top-left corner of code road and hit “review” to get to the correct level. I still had to spend the time to totally rebuild the database/tables/etc. . I then completed until about 70%, hit file->save and wrapped up for the night.

Today, I signed in to try to pick up where I left off, and the same thing - terminal progress/ database wasnt saved. Even worse, when I go to “review” in code road it won’t show me mor than the very first step in the tutorial (The first thing you need to do is start the terminal…). I can start the terminal and enter the echo hello PostgreSQL but CodeRoad still won’t show anything more when I click the top-left “review” button. Despite this, it won’t acknowledge the finished first step since it is still checking for me to successfully complete the tutorial step I reached yesterday (“characters” should have the “name” column as its primary key.

This is very demoralizing since its now 2 days in a row I’ve lost multiple hours of progress. And for what its worth, the terminal had been extremely finicky when I’m in postgresql. It would often add roughly 20 spaces if I tried to hit backspace, and then either refuse to backspace to where my input left off, or the command wouldn’t go through correctly if I did manage to backspace through all the spaces and finish typing.

This feels like when I was in the front end dev projects, and I used the provided codesandbox link to start my projects, only to spend hours testing/researching how to get react-redux to work and find out that codesandbox actually wouldn’t work and I had to use replit from another forum post.

Sorry for the troubles everyone, the courses can be finicky. I know it’s not always possible, but I would recommend to try and finish a course in one session.

If your container shuts down, the database will not be saved as far as I am aware - when you start a course back up after that, the reset button in CodeRoad should reset any files or databases to where they should be at the start of the step you are on. So click the reset button to rebuild databases and copy other needed files.

I will see if I can reproduce some of the issues with continuing courses after taking a break. There may be some bugs there that can be fixed to improve things.

the terminal had been extremely finicky when I’m in postgresql

Yea, I’ve noticed that. After you enter a command, it will sometimes not show the prompt for your next command. If you hit enter again, when there’s no prompt, a fresh prompt will show up and that issue should go away for that command.

1 Like

Here’s another post with some similar issues: CodeRoad - Build a Kitty Ipsum Translator - #5 by pkdvalis

That person said they were sent back to step 1 after opening a project that had timed out. They then let it time out again, and when they opened it a second time, it was back where they left off.

It probably doesn’t have to do with it being the second time they reopened it - just that this time, coderoad found the correct step, and it didn’t on the other try for some reason.

Feelin’ for you bro…

For database projects it’s helped me a lot to build each command in a local text editor or google doc first, then just paste it in when it’s totally ready.

This way I also keep a full history of commands to build a database

1 Like

I know this response isn’t for me but thx for the great advice!

1 Like

It wasn’t the second time, I had tried opening it a few times and trying different things. Eventually one of the tries it just worked…

Similar problems again:

So no matter what, the database will never be saved it the workspace goes to sleep?

Try this, it might help:

I want to test it more, but so far I was able to wake up a workspace on the correct step

Just to mention: the fact that CodeRoad is in the Extensions tab, means it is in the .gitpod.yml file. Also, syncing the extension would add it to your VSCode user settings (all linked environments would get CodeRoad installed - locally, CodeSpaces, any other cloud IDE).

the database will never be saved it the workspace goes to sleep?

To my knowledge, yes - from Gitpod: When a workspace stops, “Only files and directories inside /workspace are preserved.”

There’s some instructions on how to dump and rebuild databases on the first cert project if you want to do it manually for some reason: learn-celestial-bodies-database/ at main · freeCodeCamp/learn-celestial-bodies-database · GitHub - see the “notes” area. But you really shouldn’t need to do that on the practice projects. Like I said, the reset button should rebuild the databases.

I was trying to fix this error which I thought might be part of the problem. I had a similar error with my previous project

1 Like

I really appreciate the feedback everyone! I was tinkering with it before reading these responses, and I ended up logging into postgresql and found that my database had been saved from the day before. I was able to simply ctrl - enter through every tutorial step until I reached where I left off.

I’m defintely planning on using a local text editor to type out the code before pasting into terminal when ready.

Thanks again everyone!

1 Like

I have a similar problem, i tried to finish the course in one sitting, but the connection timed out, it kicked me form the session or something, i was at 70 percent, but i do see the changes in git, they are not commited, i really dont know much git, can the course be saved with the changes that i see in the git source controll tab?

What can i do to save it and recover my progress?