Not being passed Learn Bash by Building a Boilerplate

I exited from the course and when i got back it didnt pass me,i opened all the hints,changed directory but still nothing is working.Please help

@moT01 , @Sky020 , @ArielLeslie please assist

are the tests running automatically @Tkbasera263? If not, you could try clicking the run button if you haven’t. Exiting the terminal and starting it back up may get the tests to run automatically again.

If that doesn’t work, let us know - I can help debug further.

Pressed run no luck still and i exited terminal still typing echo hello website and its still not passing even after typing cd website

Did you try the reset button?

The exiting terminal bit for some reason worked after you said it but before it didnt work, thanks

2 Likes

Awesome. To explain a little - the tests look at your command history to see if you entered the right command - but the terminal needs the correct settings to put the history where the tests expect. The reset button will add that terminal config, but any opens terminals won’t be using it. So you need to exit it, and open a new one for it to use that config.

1 Like

Now it wont let me pass another challenge ive reset,clossed and opened the terminal and followed hints to the tee

You should only need to close and reopen the terminal if the tests aren’t running automatically @Tkbasera263. The hint is saying to enter:
mv header.png ..
I don’t see that in your screen shot. I would try entering that and/or do a reset and enter that.

1 Like

Thanks ill let you know how it goes when i retry/////