Number Guessing Game : I finished the project but it is not accepting my solution

I’ve done this two times, and this is not accepting my solution, some factors make me think this is a bug:

1 - It works fine with my tests, everything is as asked
2 - The site is literally wrong: I have put the correct message with the correct values
3 - The free code camp editor multiple times before didn’t function correctly
4 - I have tried using internet solutions and even they don’t work
5 - I have done it two times and it just frustrates me because it doesn’t makes any sense why it is not accepting it and saying that I didn’t put the correct message even tho in the start of this project it was marked correctly.

I just need help to solve this problem. I am going to link my github with all the project’s files:

Silencepls/Number-Guessing-Game (

One thing I noticed in the code is that you neglected to increment the number of guesses when the user makes the correct guess. (The correct guess should count as a guess)

So I would fix that and see if it helps.

I changed it but still the same.

I solved it. I refactored the code to be similar to someone’s answer. Maybe the first times didn’t work because I didn’t update the database psql file. Maybe it would be good if free code camp could make the projects more flexible to accept more range of correct answers or at least tell exactly what test didn’t work like they do with java script course

1 Like

Thank you for your suggestion to make FCC better. Bugs can be reported as GitHub Issues. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.