Prod. Landing page help

Cuéntanos qué está pasando:
I am having some troubles with the product landing page. I am getting the nav bar on the top of the viewport but somehow it is not being recognized by the test suite. Can you provide any idea on this ? Thanks!

Tu código hasta el momento

Información de tu navegador:

El agente de usuario es: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36

Desafío: Construye una página de aterrizaje de producto

Enlaza al desafío:

  • List item

@zetaontherocks, when a test fails click the red button to see which test(s) are failing and text to help you correct the issue.

  • Be sure and read more than just the first line of the failing message. The ability to read and comprehend error messages is a skill you’ll need to acquire as a developer. Ask questions on what you don’t understand.

The failing message says

The navbar should always be at the top of the viewport.
#header or one of its children should be at the top of the viewport even after scrolling : expected 440 to be close to 0 +/- 15
AssertionError: #header or one of its children should be at the top of the viewport even after scrolling : expected 440 to be close to 0 +/- 15

Do you see what the test is looking for? Not only should the navbar be at the top but it should stay at the top even after scrolling.
With your current code the navbar scrolls with the page.

Thanks Roma, understood.

Will keep on trying.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.