Pushing from C9 to Heroku failing

I am using c9 to push to heroku, except when I follow the steps from the guide they provide there is always an error.

Can someone explain each step for me? This is what I follow: https://devcenter.heroku.com/articles/heroku-cli
I am using the ubuntu method(I believe).

Which step fails and what error are you getting?

This is my gem file:

source 'https://rubygems.org'


# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '4.2.5'
# Use sqlite3 as the database for Active Record
gem 'sqlite3'
# Use SCSS for stylesheets
gem 'sass-rails', '~> 5.0'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# Use CoffeeScript for .coffee assets and views
gem 'coffee-rails', '~> 4.1.0'
# See https://github.com/rails/execjs#readme for more supported runtimes
# gem 'therubyracer', platforms: :ruby
gem 'jquery-rails'
# Use jquery as the JavaScript library
gem 'jquery-rails'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 2.0'
# bundle exec rake doc:rails generates the API under doc/api.
gem 'sdoc', '~> 0.4.0', group: :doc
# Add haml gem for writing haml code
gem 'haml', '~> 4.0.5'
# Add simple_form to create forms
gem 'simple_form', '~> 3.0.2'
# Add devise for user registrations
gem 'devise', '~> 3'
# Add acts_as_votable for voting technique
gem 'acts_as_votable', '~> 0.10.0'
# Add paperclip for image upload
gem 'paperclip', '~> 4.2.0'
# Add font-awesome-rails for emoticons
gem "font-awesome-rails"
gem 'bootstrap'
gem 'puma'
group :development, :test do
  # Call 'byebug' anywhere in the code to stop execution and get a debugger console
  gem 'byebug'
end

group :development do
  # Access an IRB console on exception pages or by using <%= console %> in views
  gem 'web-console', '~> 2.0'

  # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
  gem 'spring'
end

group :production do
  gem 'pg'
end

I get the following error when I try and run bundle install:

Your Gemfile lists the gem jquery-rails (>= 0) more than once.
You should probably keep only one of them.
Remove any duplicate entries and specify the gem only once (per group).
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 4.2.5) was resolved to 4.2.5, which depends on
      bundler (< 2.0, >= 1.3.0)

  Current Bundler version:
    bundler (2.0.1)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem 'bundler (< 2.0, >= 1.3.0)', which is required by gem 'rails (=
4.2.5)', in any of the sources.

According to logs you have incompatible rails and bundler versions.
Try to replace

gem 'rails', '4.2.5'

with

gem 'rails', '~> 5.0'

Or install older version of bundler.