Quality Assurance Node/Bcrypt Throwing Errors

Tell us what’s happening:

Here’s the link to my project on glitch.

After following the instructions of this challenge and adding Bcrypt as a dependancy, I am greeted with the following error:

Error: Cannot find module ‘/rbd/pnpm-volume/88ef0602-21b9-4f6f-8c5c-039c35e8910e/node_modules/.registry.npmjs.org/bcrypt/5.0.1/node_modules/bcrypt/lib/binding/napi-v3/bcrypt_lib.node’

I tried deleting Bcrypt and was given a different error:

ERROR ENOENT: no such file or directory, chmod ‘/rbd/pnpm-volume/88ef0602-21b9-4f6f-8c5c-039c35e8910e/node_modules/node/bin/node’

So now it looks like either way there is an error? I’m very unsure of what I’ve done wrong. I have also tried installing Bcrypt from the terminal, as well as running npm cache clean and npm cache verify as per some googling I did prior to this post but nothing appears to have changed or been fixed.

Thanks for your help!

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.82 Safari/537.36

Challenge: Hashing Your Passwords

Link to the challenge:

Update: Through further googling/trial and error I was able to solve the problem by running enable-pnpm in the terminal.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.