Quality Assurance Projects - Issue Tracker

Tell us what’s happening:
one last missed check and i have no idea:

the thing is, the GETs from the FCC website are:

  1. GET /api/issues/fcc-project?_id=6436b60410475d2f854288d6
    → this request comes before the PUT request, so it is not belonging to my issue i guess.
  2. GET /api/issues/get_issues_test_139465
    → this request comes after three POST to same project, so it will be for the check GET all issues of one project that is one check earlier as my nemesis.
  3. GET /api/issues/get_issues_test_139909?created_by=Alice
    → Alice is once in the added issues from FCC. i can see it in my Database. The error response of FCC tells us, that three objects are expected.
    here my playground query for all created_by:

The Alice GET must be part of the check that is missing.
For me it’s look a bit like a wrong check, but how could you others get pass?

My own asserts work fine (yes they could be written wrong by me :slight_smile: )

I would be so happy for any hint guys!

thx, Jens

Your project link(s)

solution: https://pw1j1l-3000.csb.app

githubLink: GitHub - Delerhon/boilerplate-project-issuetracker: A boilerplate for a freeCodeCamp project.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/112.0

Challenge: Quality Assurance Projects - Issue Tracker

Link to the challenge:

Your code passes the first time I ran it locally. Then it failed the next time on that test. If I then delete the collection it passes again.

Not sure if it is the delete part of your code that isn’t working as it should or what.

Edit: Not sure what is going on. After deleting the collection it is passing every time now.

I don’t think it ever clears the data (well except in the delete).

The tests

1 Like

Yes thx man.
That worked for me.
Delete the complete collection and then running the test.
Nice idea^^

I am curious what reason there is for this strange behavior.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.