React App modals not working and env not available

Regarding this app

inside of the file src/app.js

I have the following problems:

  1. lines 2,8, 76-81, 131
    Why isnt my app header showing? whats wrong with the way I have it set up?
    If I remove the encapsulating div tags on line 76 and on line 131 and instead place the navbar component after the Map component then everything does display, however my modals dont show anymore, so why does the bootstrap css im trying to use for my header stop my modals from displaying and how can I fix it?

  2. lines 17-19
    Realizing the the keys have been exposed in all the prior commits anyways it does not matter now, however for the future I want to know:
    The following from the freecodecamp curriculum exercise would have you believe that everything in env is available as a global under process.env.VarName however this simply does not work, I have tried process.env.local and ive also tried to module.exports from the env file nothing has worked. seems the only way I can make it work is If i have the keys all exposed to the public in the regular file. As one last try I tried to import it, as you can see on line 6 in the app.js file… although if its available as global I should not have to import it or export it. What I say is correct? Ive tried everything but its refusing to recognize anything in the env.
    currently my env looks like this

module.exports = {
  TICKETMASTER_KEY:'4rTME5oHYcimuAeEz6QFqG0XSB1gHhC9',
  REACT_APP_MAPBOX_API:'pk.eyJ1IjoiZ3JleWtyYXYiLCJhIjoiY2p4bXlwb3NjMDkwdDNobzZkYXIxeTB2bCJ9.23vaPNjrffSym1U2FJbPVw'
} 

Edit: to replicate the problem from issue #1, clone the repo, and then click on the little button in the upper left that says ‘click me’ click on one of the skateboarding icons and youll see the modal of the event, no need to click on the geolocation icon. try to see if you can get the header to display along with the map and still have the modal functionality working when you click on an icon. Let me know what you did to solve it.

I should mention the modals are not bootstrap but from someone elses codepen project and ive taken their css. but is this how it works that I can only use the bootstrap modals and I cant use my own custom modals? What is the conflict?