React unable to deploy my e-commerce project

When ever I try to deploy the project the it shows the error of "error expect@29.4.1: The engine “node” is incompatible with this module. Expected version “^14.15.0 || ^16.10.0 || >=18.0.0”. Got “16.4.2"”

link to my project.

Looks like they haven’t updated their docker images. I have never used Fleek but it personally doesn’t instill much confidence in me.

Maybe you can try a different image and see if it works.


I tried using the teracy but it did not work

Didn’t work how, what happens?

I tried using a fresh CRA and it deploys using the docker image I posted.

When I used the teracy it have been stuck and not being able to process further.

I used node:lts and it worked my webapp was deployed but my webapp show nothing.
Please look into the image as it shows this error.

The image name is teracy/create-react-app:latest

I used image name teracy/create-react-app:latest
It deployed successfully but stil there some error.

When I cloned your repo locally and ran it in dev mode, I see errors you need to resolve before you try and deploy it. That is probably why you are seeing errors on the deployed site.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.