Remove the border, and add 2rem of padding only to the top and bottom of each fieldset. Be sure to remove the padding from the left and right

Tell us what’s happening:
Describe your issue in detail here.
.fieldset {
padding: none;
border: 0;
padding-top: 2rem;
padding-bottom: 2rem;
padding-left: none;
padding-right: none;
}
I put this code which right but it says You can use either a value of none or 0 to remove the border . That I could not understand at all

   **Your code so far**
/* file: index.html */
<!DOCTYPE html>
<html>
 <head>
   <title>Registration Form</title>
	  <link rel="stylesheet" type="text/css" href="styles.css" />
 </head>
 <body>
   <h1>Registration Form</h1>
   <p>Please fill out this form with the required information</p>
   <form action='https://register-demo.freecodecamp.org'>
     <fieldset>
       <label>Enter Your First Name: <input type="text" name="first-name" required /></label>
       <label>Enter Your Last Name: <input type="text" name="last-name" required /></label>
       <label>Enter Your Email: <input type="email" name="email" required /></label>
       <label>Create a New Password: <input type="password" name="password" pattern="[a-z0-5]{8,}" required /></label>
     </fieldset>
     <fieldset>
       <label><input type="radio" name="account-type" /> Personal Account</label>
       <label><input type="radio" name="account-type" /> Business Account</label>
       <label>
         <input type="checkbox" name="terms" required /> I accept the <a href="https://www.freecodecamp.org/news/terms-of-service/">terms and conditions</a>
			  </label>
     </fieldset>
     <fieldset>
       <label>Upload a profile picture: <input type="file" name="file" /></label>
       <label>Input your age (years): <input type="number" name="age" min="13" max="120" />
			  </label>
       <label>How did you hear about us?
         <select name="referrer">
           <option value="">(select one)</option>
           <option value="1">freeCodeCamp News</option>
           <option value="2">freeCodeCamp YouTube Channel</option>
           <option value="3">freeCodeCamp Forum</option>
           <option value="4">Other</option>
         </select>
       </label>
       <label>Provide a bio:
         <textarea name="bio" rows="3" cols="30" placeholder="I like coding on the beach..."></textarea>
			  </label>
     </fieldset>
     <input type="submit" value="Submit" />
   </form>
 </body>
</html>
/* file: styles.css */
body {
 width: 100%;
 height: 100vh;
 margin: 0;
 background-color: #1b1b32;
	color: #f5f6f7;
 font-family: Tahoma;
	font-size: 16px;
}

h1, p {
 margin: 1em auto;
 text-align: center;
}

form {
 width: 60vw;
	max-width: 500px;
	min-width: 300px;
	margin: 0 auto;
}

.fieldset {
 padding: none;
 border: 0;
 padding-top: 2rem;
 padding-bottom: 2rem;
 padding-left: none;
 padding-right: none;
}

label {
	display: block;
	margin: 0.5rem 0;
}

   **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.67 Safari/537.36

Challenge: Step 40

Link to the challenge:

Phew, that title’s a bit of a read. In the future it might be best to shorten it, and place details in the post. :smile:
Easier to read, and it’s easier to search.

So what seems to be the issue? Something you don’t understand? An error message? The more info you give us the better we can help.


I see two things that are off, and a couple that could be improved.

First, your selector. The step seems to indicate they want you to style fieldset elements rather than fieldset classes. Using a period in a CSS selector indicates it’s a class.

Second, I don’t believe none is a valid value for padding/padding-left/padding-right. If you want to remove padding set it to 0.

On to improvements.

If you set padding to 0, what’s the use in setting padding-left and padding-right to the same? Seems a little redundant.

Lastly, I don’t know if they’ve taught it yet, but you could use the padding shorthand when you need to set all 4 sides at once:

Mod edit: solution removed.

1 Like

“fieldset” not “.filedset”
and padding not use “none”

1 Like

The right solution…
Mod edit: solution removed

I had the same issue. The instructions said that you can use none or 0. I changed from none to 0 and it worked.

Final warning: please do not share solutions here.