Why have you defined two separate functions here (both of which have the same name)?
Your getGrade function already returns a grade based on the student’s score, so you don’t need to do this work again in the hasPassingGrade function.
All that you need to do in hasPassingGrade is check whether or not the grade returned by getGrade is ‘F’. As ‘F’ is the only failing grade, you should return false if the grade is ‘F’ and true if it is any other value. Your second hasPassingGrade function is actually fine, except that you don’t need the final line of code, as you are already returning a true or false value in the line above it.
Why do you have this? This logic is already handled in the getGrade function. Your hasPassingGrade function should return only true or false, depending on the grade returned by getGrade.