Role playing game step 86 - semi colon error

Hello,
I have read the other posts regarding this step, and believe I have a separate issue. I followed the directions, and my answer looks like what is indicated in the other questions, but I keep throwing a semi-colon error, even though I have one present. Also, I have tried resetting/reloading the lesson, and now it doesn’t even respond to my changes, or direct me to the forum after so many attempts.

Screenshot below, since its not letting me copy/paste to the post normally.

Please post a link to the Step.

Yo should be able to use Ctrl+c and Ctrl+v on your keyboard still.


That is a syntax error where the red squiggle line is. The increment operator is only ++, not 1++. Also the increment operator should come right after the variable name, without a space.

Thank you Jeremy!!

This is a link to the step
https://www.freecodecamp.org/learn/javascript-algorithms-and-data-structures-v8/learn-basic-javascript-by-building-a-role-playing-game/step-86.

I went back on to the page after taking a break, and the help button and other components were present. hmm…

Also, your hints worked!! Thank you :wink: